[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #12609] File hurd/physmem.h is absent

From: anonymous
Subject: [bug #12609] File hurd/physmem.h is absent
Date: Fri, 8 Apr 2005 20:24:50 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050304 Firefox/1.0.1

Follow-up Comment #2, bug #12609 (project hurd):

thank you, Alexandre.
But when i tried to compile without libc, i'v got same error.

then i make symlink:
$ cd hurd
$ ln -s ../physmem/physmem.h ./
$ cd ..
$ make
then it follow the compilation, but break it when linking laden,
due to undefined reference to __chk_fail:
make[2]: Entering directory `/usr/home/yasha/work/gnu/hurd-l4/laden'
gcc  -std=gnu99 -Wall -g -O3   -o laden -u_start -e_start -N -nostdlib
-Ttext=0x190000 ia32-crt0.o laden-ia32-
cmain.o laden-ia32-output.o laden-output-vga.o laden-output-serial.o
laden-ia32-shutdown.o laden-output.o lade
n-output-none.o laden-shutdown.o laden-loader.o laden-laden.o
laden-kip-fixup.o -lgcc ../libc-parts/libc-parts
../libc-parts/libc-parts.a(memcpy.o)(.text+0xa): In function `__memcpy_chk':
: undefined reference to `__chk_fail'
../libc-parts/libc-parts.a(memset.o)(.text+0xa): In function `__memset_chk':
: undefined reference to `__chk_fail'
collect2: ld returned 1 exit status
make[2]: *** [laden] Error 1
make[2]: Leaving directory `/usr/home/yasha/work/gnu/hurd-l4/laden'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/home/yasha/work/gnu/hurd-l4'
make: *** [all] Error 2

What goes wrong there?

 - Joe-Jim


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]