[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

First Booting of L4-Hurd

From: arief#
Subject: First Booting of L4-Hurd
Date: Wed, 02 Feb 2005 15:24:37 +0700

Dear all.

Seing on kerneltrap today that there has been some progress on L4-Hurd
(though I don't really understand what it mean), I try to get l4-hurd to

First downloading from CVS, using cvsgrab because I don't have direct
connection and my proxy is prohibiting CVS port.

Following instruction on the README, and then using pistachio-demodisk
as a base. And then booting with the following menu.lst:

title  GNU Hurd on L4
kernel /boot/laden -D -o serial,uart1,speed=9600
module /boot/ia32-kernel
module /boot/sigma0
module /boot/wortel -D -o serial,uart1,speed=9600
module /boot/physmem
module /boot/task
module /boot/deva
module /boot/task
module /boot/ruth

and then using qemu like this:
qemu -dummy-net  -serial stdio -fda pistachio-ia32-0.4-demodisk.bin
-boot a

All I get is this:

laden:main: laden 0.0
laden:debug_dump: Booted by GNU GRUB 0.90-os
laden:debug_dump: Memory: Lower 639 KB, Upper 130048 KB
laden:debug_dump: Module 1: Start 0x198000, End 0x1c1f49,
Cmd /boot/ia32-kernel
laden:debug_dump: Module 2: Start 0x1c2000, End 0x1c9248,
Cmd /boot/sigma0
laden:debug_dump: Module 3: Start 0x1ca000, End 0x1d479c,
Cmd /boot/wortel -D -o serial,uart1,speed=9600
laden:debug_dump: Module 4: Start 0x1d5000, End 0x1eb128,
Cmd /boot/physmem
laden:debug_dump: Module 5: Start 0x1ec000, End 0x2040fc, Cmd /boot/task
laden:debug_dump: Module 6: Start 0x205000, End 0x21d0e0, Cmd /boot/deva
laden:debug_dump: Module 7: Start 0x21e000, End 0x2360fc, Cmd /boot/task
laden:debug_dump: Module 8: Start 0x237000, End 0x247bb0, Cmd /boot/ruth
laden:debug_dump: Memory Map 1: Type 1, Base 0x0, Length 0x9fc00
laden:debug_dump: Memory Map 2: Type 1, Base 0x100000, Length 0x7f00000
laden:loader_add_region: Protected Region: laden (0x190000 - 0x196004)
laden:loader_add_region: Protected Region: grub-mbi (0x3eaa0 - 0x3eb00)
laden:loader_add_region: Protected Region: grub-mods (0x26d20 - 0x26d80)
laden:loader_add_region: Protected Region: grub-mods-cmdlines (0x2049 -
laden:loader_add_region: Protected Region: kernel-mod (0x198000 -
laden:loader_add_region: Protected Region: sigma0-mod (0x1c2000 -
laden:loader_add_region: Protected Region: rootserver-mod (0x1ca000 -
laden:loader_add_region: Protected Region: kernel (0x100000 - 0x142f9c)
laden:loader_add_region: Protected Region: sigma0 (0x40000 - 0x483a0)
laden:loader_add_region: Protected Region: rootserver (0x300000 -
laden:kip_fixup: KIP found at address 0x115000.
laden:kip_fixup: Sigma0: Low 0x40000, High 0x483a0, IP 0x41c70, SP 0x0
laden:kip_fixup: Root: Low 0x300000, High 0x30ba50, IP 0x300000, SP 0x0
laden:kip_fixup: Memory Map 1: Type 4/0, Low 0x0, High
laden:kip_fixup: Memory Map 2: Type 1/0, Low 0x0, High 0x9f800
laden:kip_fixup: Memory Map 3: Type 1/0, Low 0x100000, High 0x7fffc00
laden:kip_fixup: Memory Map 4: Type 4/0, Low 0xa0000, High 0xefc00
laden:kip_fixup: Memory Map 5: Type 2/0, Low 0x7000000, High 0x8000000
laden:kip_fixup: Boot Info: 0x3eaa0
laden:main: Entering kernel at address 0x142000...

And then something that says:
CPU does not support all features (1002809) -- halting

Haven't try to debug anything yet, just wanna make sure I've done it

Tried to change kernel menuconfig using Pentium2/3, still not succeded.

I'm using Debian/Unstable on an IBM Thinkpad T30 laptop.

Anyway, congrats on the hard work...

Best Regards.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]