[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub/laden bugs

From: Niels Möller
Subject: grub/laden bugs
Date: 27 Aug 2003 14:57:56 +0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.2

I think I've figured out why I couldn't boot my task server (or any
root server, for that matter) using laden. That's where I got stuck i
few months ago, when I tried to use Neal's version of laden, only
updated for the latest version of pistachio. Now I tried Marcus'
version, and it also didn't work, but it gave some more explicit error

It turns out that when laden reads the memory map from grub, it
consists of three correct (as far as I can tell) entries, followed by
three bogus ones. The mapping is something like

n  base        length       type
1         0x0     0x9 fc00  1
2    0x9 fc00        0x400  2
3   0x10 0000  0x1fee 2800  1
4 0x1ffe 2800     0x1 d800  2
5 0xfeda 0000     0x6 0000  2
6 0xffb8 0000    0x48 0000  2

After hacking laden to ignore entries 4-6, things seemed to work, and
I got some debug output from my root-server.

I don't know if this is a bug in grub or in laden (or in the BIOS
*shudder*). Curiously, it seems to work if I use pistachio's kickstart
program instead of laden, but that doesn't necessarily mean that it's
laden's fault.

I'm using the debian package grub-0.91-2.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]