[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Thoughts about the new X.2 spec...

From: Espen Skoglund
Subject: Re: Thoughts about the new X.2 spec...
Date: Mon, 4 Feb 2002 12:12:52 +0100

> I really dislike TheWayOfNamingFunctions. IMHO (and a lot of people
> share my opinion, it's even in the GNU Coding Standards) that's
> ugly, but it seems to be some sort standard for OO languages. I
> think names_like_this are much better.

I really hope that this is the last time function/variable naming for
the L4 API will be discussed (on the other hand, every specification
needs to have some bikesheds, right? ;-) If people like the other way
of naming they can simply have some header file that redefines the
names.  E.g.:

   #define L4_SpaceControl      l4_space_control
   #define L4_ReplyWait         l4_reply_wait

So, can we please let these silly non-problems rest?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]