[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Sample code for L4Ka now available

From: Farid Hajji
Subject: Re: Sample code for L4Ka now available
Date: Mon, 20 Nov 2000 01:37:34 +0100

> > I'd like to announce that the ChacmOS project is now available for
> > download from http://www.l4ka.org/projects/chacmos/.
>   Great! That's useful, really.
This is exactly the kind of example code we need to learn more about L4.
A big Thank You!

>   BTW, I found two problems when building it. The one is that it
> assumes that the top-level Makefile exports variables to
> sub-makes. This is not always true, unless you specify exported
> variables explicitly. So I needed to add this line into the Makefile:
> export IDL4 LD TFTPDIR
That's true. I also had to change every call to make in the Makefile with
calls to gmake (I'm using FreeBSD which comes with two make variants,
gmake being GNU make). It would be nice to parameterize this in a
MAKE environment variable if possible (but that's not critical at all).

Everything built fine here.

> The other is that "german.sty" is not included in the standard LaTeX
> distribution. In fact, the file is not found in my system (even though
> I can read German a bit). I'd recommend that you distribute the file
> with the ChacmOS tarball.
Well, german.sty is included on teTeX-1.0.7 (perhaps earlier teTeX as
well) on my box, so I had no problems there. It was good though that
lpd was not started and that I've looked at the lpq recently (Wew!).
It would be good to remove that target from 'make all'.

I tried to boot chacmos as instructed, but got the following error
message in KD: (the part that is still visible)

  module 6 : (fd0)/l4ka/ramdisk
      start = 1b4000, end = 1c4000
  module 7 : (fd0)/l4ka/shell
      start = 1c4000, end = 1cb4ea

  Task 5: (fd0)/l4ka/memsvr
  upf (e0050000): e04ca7d8 @ 000000dd, err: 0000fffc
  --- KD# user touches kernel area ---

This is what GRUB said while loading the modules:

  kernel=(fd0)/l4ka/rmgr -sigma0 -roottask
    [Multiboot-elf, <0x111000:0x20734:0x0>, <0x132740:0x48c:0xffc8>,
    [Multiboot-module @ 0x143000, 0x1272c bytes]
    [Multiboot-module @ 0x156000, 0x287a bytes]
    [Multiboot-module @ 0x159000, 0x1d519 bytes]
    [Multiboot-module @ 0x177000, 0xe87c bytes]
    [Multiboot-module @ 0x186000, 0x14e06 bytes]
    [Multiboot-module @ 0x19b000, 0x18090 bytes]
    [Multiboot-module @ 0x1b4000, 0x10000 bytes]
    [Multiboot-module @ 0x1c4000, 0x74ea bytes]

This could have something to do with LINK_BASE, right? I've already
seen this kind of error the first time I've tried the sample root_task.
Modifying (reducing) LINK_BASE worked there. What should be done in
this case?



Farid Hajji -- Unix Systems and Network Admin | Phone: +49-2131-67-555
Broicherdorfstr. 83, D-41564 Kaarst, Germany  | address@hidden
- - - - - - - - - - - - - - - - - - - - - - - + - - - - - - - - - - - -
Murphy's Law fails only when you try to demonstrate it, and thus succeeds.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]