[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [New GUI] Wrapper groups

From: Libor Polčák
Subject: Re: [New GUI] Wrapper groups
Date: Wed, 6 Oct 2021 15:03:37 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/

analytics can be called analytics or we can rename to Beacons or do you have a 
better name?
We should provide on/off levels
* xhr - I do not know if we want to keep this wrapper. It does not prevent the 
page form using Fetch API, RTC and other methods.


I do not think that we should keep the XHR wrapper (if we do, it should be 
enabled only optionally). As https://github.com/polcak/jsrestrictor/issues/132 
points out, Beacons and XHR are similar. So it might make sense to rename 
analytics and/or treat XHR and Beacon similarly.

I did not experience any problems with disabled Beacons, yet.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]