[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] /dev/null - Permission denied

From: Olivier Sessink
Subject: Re: [Jailkit-users] /dev/null - Permission denied
Date: Sun, 24 Nov 2019 17:18:43 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

On 24-11-19 12:57, Branislav Viest wrote:
Hello guys,

I am experiencing strange problem under Debian Buster (not tested on Debian Stretch) with Jailkit and SSH. In the Jailkit chroot / jail I want to use SSH client (incl. SCP and rsync over SSH) but I always got error:

Couldn't open /dev/null: Permission denied

I tried to re-create /dev/null under chroot and in the base system, perms looks fine. I also tried to create a brand new jailkit chroot but same error out there. I read all about this issue on internet resources but I am not able to get it working... Any ideas? It is serious issue for me and our clients.

Perms in /dev in chroot:

$ ls -l /dev
total 4
srw-rw-rw- 1 root root    0 Nov 22 09:14 log
crw-rw-rw- 1 root root 1, 3 Nov 24 10:52 null
drwxr-xr-x 2 root root 4096 Oct 18 07:16 pts
crw-rw-rw- 1 root root 1, 8 Oct 16 11:13 random
crw-rw-rw- 1 root root 5, 0 Oct 16 11:13 tty
crw--w---- 1 root root 4, 0 Oct 16 11:13 tty0
crw--w---- 1 root root 4, 4 Oct 16 11:13 tty4
crw-rw-rw- 1 root root 1, 9 Oct 16 11:13 urandom

Perms in /dev in base system:
ls -l /dev | grep null
crw-rw-rw- 1 root root      1,   3 říj 19 20:28 null

what does

stat /dev/null

stat <path to jail>/de/null

look like?


Bluefish website http://bluefish.openoffice.nl/
Blog http://oli4444.wordpress.com/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]