[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] Debian Upgrade broke Jails, How to Fix

From: Olivier Sessink
Subject: Re: [Jailkit-users] Debian Upgrade broke Jails, How to Fix
Date: Thu, 12 Apr 2012 18:28:02 +0200
User-agent: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20120329 Thunderbird/11.0.1

On 03/20/2012 04:18 AM, Chris Tankersley wrote:
I'm running Debian 6, and the last big update seems to have broken some,
but not all, of my jails. I had installed the server as Debian 6 and
Jailkit 2.14 and set up about 8 jails for different users. Everything
worked great until the update when a few of the jails started to
segfault when running commands. For example, I could log in as the
jailed user 'bob', but when I ran `ls` I received a segfault message.

I tried to update these broken jails with jk_update, but the command
just dropped back to a command prompt as if there was nothing to do. I
then removed all the directories created by jailkit except for the
user's home directory, and recreated the jail like this:

jk_init -c /etc/jailkit/jk_init.ini /var/www/clients/mydomain.com
<http://mydomain.com> extshellplusnet
jk_init -c /etc/jailkit/jk_init.ini /var/www/clients/mydomain.com
<http://mydomain.com> limitedshell
jk_cp -j /var/www/clients/mydomain.com/ <http://mydomain.com/> -k /bin/bash
jk_jailuser -s /bin/bash -j /var/www/cients/mydomain.com/
<http://mydomain.com/> bob

I could log in and run commands, but the prompt now shows 'I have no
address@hidden', like the jail cannot see /etc/passwd. I checked and there
is a proper /etc/passwd file in the jail:

perhaps one of the libnss*.so files that is responsible for /etc/passwd
is missing? You might want to jk_cp all libnss*.so files into the jail.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]