[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] debian x64 probably bash-library related problem

From: Martin
Subject: [Jailkit-users] debian x64 probably bash-library related problem
Date: Mon, 28 Mar 2011 11:59:18 +0200
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20110303 Lightning/1.0b2 Thunderbird/3.1.9

Hi there,
I am running Linux 2.6.32-5-xen-amd64 #1 SMP Wed Jan 12 05:46:49 UTC 2011 x86_64 GNU/Linux, my problem is probably related to lib64 or something like that. When I am logged as user inside jail, i cannot execute some basics in bash. I tried several ways how to fix this but I am not successful till now. Every time i try to execute binary with bash script it will stdout : No such file or directory, I checked 777, chmod is set and even owner and group are my id's. When i cd to directory in terminal, and run ./binary it will tell me again : No such file or directory. I've googled that it can be related to x64 and something with bad "jk_update" of /lib, /lib32 and /lib64 from real system to jail.
I've also tried several versions of jailkit but nothing helped.

su'ed as user jailer to jail:
address@hidden:~$ cd /home/2704
address@hidden:/home/2704$ ./i686
bash: ./i686: No such file or directory
address@hidden:/home/2704$ ls -la | grep i686
-rwxrwxrwx  1 jailer jailer   177498 Mar 28 08:18 i686

Am I doing something wrong ?

address@hidden:/$ ldd /bin/bash
    linux-vdso.so.1 =>  (0x00007ffff65ff000)
    libncurses.so.5 => /lib/libncurses.so.5 (0x00007f2e8a124000)
    libdl.so.2 => /lib/libdl.so.2 (0x00007f2e89f20000)
    libc.so.6 => /lib/libc.so.6 (0x00007f2e89bbe000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f2e8a36e000)

Thanks for reply/help,
best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]