[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] Jailkit and stripped down puppy linux 3.01

From: Louis Sadava
Subject: [Jailkit-users] Jailkit and stripped down puppy linux 3.01
Date: Wed, 18 Aug 2010 10:01:57 -0700

Hi there,


I’m looking for some advice on using jailkit on a stripped down version of puppy linux 3.01 in an embedded system. I am fairly new to linux and have spent the last couple days trying different things to restrict a shell user to their home directory. I think I have the correct passwd line: [user:x:25005:25005:Linux User,,,:/home/userjail/./home/user:/usr/sbin/jk_chrootsh].


When I type ‘login’ and try to login as this user it leaves me with <root> and outputs no error message.  When I run jk_check it outputs ‘/usr/sbin/jk_check:38: DeprecationWarning: the md5 module is deprecated; use has hlib instead                 import md5.       /home.’  


When I run jk_update it says: ‘ERROR: while scannign dir /home/userjail/bin/: No such file or directory                  ERROR: while scannign dir /home/userjail/opt/: No such file or directory’



Any idea’s? I am thinking that there is something missing in my stripped down OS but I’m not sure what..


Louis Sadava, B.Eng

Precision Microdynamics inc.

Electrical Engineer


+1 (250) 382 7249 Work

+1 (250) 217 7734 Cell



reply via email to

[Prev in Thread] Current Thread [Next in Thread]