[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] I can't add jailed users

From: Becky Johnson
Subject: [Jailkit-users] I can't add jailed users
Date: Mon, 9 Aug 2010 12:55:43 -0700

Today I set up jailkit and no matter what I cannot get users to login properly.
Here is a complete list of what I tired.

I wanted a jailed folder with scp and sftp.

First I did these commands:

mkdir /var/www/vhosts/NAME_OF_DIRECTORY
jk_init -j /var/www/vhosts/NAME_OF_DIRECTORY jk_lsh
jk_init -j /var/www/vhosts/NAME_OF_DIRECTORY sftp
jk_init -j /var/www/vhosts/NAME_OF_DIRECTORY scp


adduser demo
passwd demo

(make the password for the user)


# jk_jailuser -j /var/www/vhosts/wimaxcsv test
home directory /home/test is not within /var/www/vhosts/wimaxcsv/, move the 
directory contents?

Said no.

I did this once before with yes but then it logged the user into it's home 
directory instead of the folder directly above the home folder where we 
actually want people to login to.

We just want to keep home/  at the very top of our whole directory.  The user 
folder was created at /home/demo. which is what we want. But it still didn't 

jk_jailuser -j /var/www/vhosts/NAME_OF_DIRECTORY demo

Edited my ini file:


paths= /usr/lib/, /usr/sbin
executables= /usr/lib/sftp-server, /usr/bin/scp
#allow_word_expansion = 0
#umask = 002

Tested the user and got:

Could not connect to server.  The user name or password was not accepted by the 

I know my username and password are correct.

This is what shows in my password file:
demo:x:10013:10014::/home/demo:/usr/sbin/jk_lsh   No idea if my uid is 
correct... Not sure what it was copying it from.

Also, tried using the command jk_addjailuser and entered my path to the jail 
and got cannot create directory  /var/www/vhosts/NAME_OF_DIRECTORY/./home/demox

Please help! I have tried as many things as I can think of to make this work.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]