jailkit-users
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] Problem to establish a SFTP for windows


From: yellow protoss
Subject: Re: [Jailkit-users] Problem to establish a SFTP for windows
Date: Thu, 15 May 2008 12:16:45 +0200

Dear Oliver,
 
I found this:
Der Standard SSH/SCP/SFTP-Port hat die Nummer 22. FTP funktioniert ├╝ber den Tunnel nur im "passive mode".
 
Would you know if "apt-get install sftp-server " like, will it give a SCP or SSH connection ?
I'd actually rather use SSH than SCP encryption for my data. Then the data will not be jailed if I understand well with this sftp-server server like   (instead of via the ssh server for ur case)

Regards
Yellow

 
On 5/13/08, yellow protoss <address@hidden> wrote:

Hi Oliver,
 
SInce it will never work, could you please post a ls -la or tree or/and tar.gz
of a working jail with sftp ??
with all the config files
 
One could also a typical tar.gz on rapidshare or megaupload uploading ..
Please please
 
Kind regards,
 
Yellow

 
On 5/9/08, yellow protoss <address@hidden> wrote:

I found this, but it does not help unfortunately. I have just added scponly package as here said: http://wiki.dns323.info/howto:securing_sftp
but it still does not work :(
 
Sincerely,
Yellow
 
On 5/8/08, Olivier Sessink <address@hidden> wrote:
yellow protoss wrote:
Dear Oliver,
 I am pleased to confirm you the use of SFTP on a specific port. The sftp program was under a Linux system core, i.e. Debian stable.
I would like to submit you the following output results that was given by the grep function, that you provided me today in order to give help in the installation of the sftp server. Unfortunately the syslog things is for me very unclear, and a step by step procedure would be very welcome. Every single parts of the Linux system are still for me not known in the deepest knowledge, unfortunately. The output hence is as follows (I would note that the /ho:... chrootusers/etc/passwd is contains like it should the jk_lsh now):
 # grep jk_ /var/log/*  | grep 22
/var/log/auth.log:May  6 19:40:07 localhost jk_chrootsh[22869]: abort, path /home/chrootusers is setgid

fiorst fix this issue:
`chmod g-s /home/chrootusers/`

/var/log/auth.log:May  6 19:40:07 localhost jk_chrootsh[22869]: abort, path /home/chrootusers is not a safe jail, check ownership and permissions

could be the above issue, perhaps there are more issues

/var/log/auth.log:May  6 22:24:19 localhost jk_chrootsh[29119]: ERROR: failed to execute shell mkdir ~/logged;/bin/bash for user MIJNLOGINMAARHETISNIET (ZZZZ), check the permissions and libraries of /home/chrootusers/mkdir ~/logged;/bin/bash

this seems to be an issue with the shell of the user inside the jail here

[..]
/var/log/auth.log:May  8 22:06:36 localhost jk_lsh[20518]: jk_lsh version 2.1, started
/var/log/auth.log:May  8 22:06:36 localhost jk_lsh[20518]: WARNING: user MIJNLOGINMAARHETISNIET (ZZZZ) tried to get an interactive shell session (/usr/sbin/jk_lsh), which is never allowed by jk_lsh

how dod you try to logon here? it seems you tried to ssh to the account, but you are using jk_lsh so ssh for an interactive shell is blocked.

regards,

       Olivier


_______________________________________________
Jailkit-users mailing list
address@hidden
http://lists.nongnu.org/mailman/listinfo/jailkit-users




reply via email to

[Prev in Thread] Current Thread [Next in Thread]