[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] jk_chrootlaunch processes staying around?

From: Gregory Piñero
Subject: Re: [Jailkit-users] jk_chrootlaunch processes staying around?
Date: Tue, 30 Oct 2007 09:43:40 -0400

On 10/30/07, Olivier Sessink <address@hidden> wrote:
> > 1. Why are these root process sticking around?
> it's the /bin/sh process sticking around, not the jk_chrootlaunch. So I
> don't know how you start these 4 processes, but I guess it's some
> script, and this script is the reason you see 4 /bin/sh processes.

Yeah, it's a Python script that launches these processes.  If it helps
here's the relevant code used to launch each process:

def launch_worker():
    """Launch a single worker. Use jailkit"""
    #change for python version if needed e.g., 2.4
    command="""jk_chrootlaunch -u jailtest -g jailtest -j
/srv/jail_for_python/ --exec /usr/bin/python2.5 exec_worker.py"""
    proc = 
    logging.info("Launched worker:%s with PID %s" % (URI,PID))
    return worker,PID

Here's the other twist with this problem.  I'm not sure if it's
relevant.  When I run this script that launches the 4 processes on my
home computer (Ubuntu Dapper) it doesn't exhibit this behavior.  It
only lists the 4 /usr/bin/python2.5 exec_worker.py processes.

It's only when I run it on my VPS, running Ubuntu 7.04 that this
behavior shows up.  You know, the VPS has Python 2.5, and my home
computer has Python 2.4.  I wonder if that could make the difference?

Of course, if you're sure it's not a jailkit issue, I guess I should
move on to it being either a Python issue, an OS issue, or a VPS


reply via email to

[Prev in Thread] Current Thread [Next in Thread]