[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] SuSE problem

From: Olivier Sessink
Subject: Re: [Jailkit-users] SuSE problem
Date: Tue, 05 Jun 2007 23:16:39 +0200
User-agent: Icedove (X11/20070329)

Steve Follmer wrote:
I tried the suggestion and here is my new situation.
It just closes the session with no explanation:

sftp address@hidden
Connecting to localhost...
Connection closed

Nothing in /var/log/warn, this is in /var/log/messages:

Jun  5 13:07:11 suse sshd[8030]: Accepted keyboard-interactive/pam for
test from port 59060 ssh2
Jun  5 13:07:11 suse sshd[8036]: subsystem request for sftp
Jun  5 13:07:11 suse jk_chrootsh[8037]: now entering jail /home/sftp for
user test (1005)
Jun  5 05:07:11 suse jk_lsh[8037]: jk_lsh version 2.3, started
Jun  5 05:07:11 suse jk_lsh[8037]: executing command
'/usr/lib/ssh/sftp-server' for user test (1005)

I tried this, but the trace file is empty...
ps axu | grep sshd | grep test
root      8079  0.0  0.1   7856  2492 ?        Ss   13:13   0:00 sshd:
test [priv]
sshd      8083  0.0  0.0   7196  1344 ?        S    13:13   0:00 sshd:
test [net]
root      8084  0.0  0.0   7988  1692 ?        S    13:13   0:00 sshd:
test [pam]

# strace -p 8083 -ff -e trace=file -o t2
Process 8083 attached - interrupt to quit
Process 8083 detached

I *guess* you have to trace the children of process 8079 in the above example. Not sure though. Give it a try. You should see multiple tracefiles, jk_chrootsh will have a different tracefile from jk_lsh and that will be different from sftp-server etc.

if you don't see anything unusual in the traces, you can post them to the list.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]