[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Jailkit-users] Need help deciphering error [SOLVED]

From: Scott Ruckh
Subject: Re: [Jailkit-users] Need help deciphering error [SOLVED]
Date: Sat, 14 Oct 2006 10:02:16 -0700 (MST)
User-agent: SquirrelMail/1.4.8-2.el4.centos4

This is what you said Olivier Sessink
> Scott Ruckh wrote:
>> I am trying to set up a SFTP jail.  I already had users set up working
>> in
>> a SHELL jail, but can not get this particular user to work.
>> I am getting the following error:
>> jk_lsh[#####]: uid ### or gid ### does not have a name
> this means that jk_lsh is inside the jail, and it cannot find the
> username or groupname corresponding to the user id or group id it is
> started with. Could be that some libnss* files are missing (on a 64bit
> system you might need to copy extra libnss* files from /lib64 or so).
> Or perhaps the user or group is simply not listed in the
> <jail>/etc/passwd or <jail>/etc/group files.
> the latest cvs snapshot has better explaining log messages for this
> situation.
> regards,
>       Olivier

Yes this was a 64-bit system, and yes, copying over the libnss* files
solved the problem.

I will eventually get around to upgrading Jailkit.

Thank you for the work and for the support!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]