[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Jailkit-users] [Fwd: Trouble with perl program on Gentoo Linux]

From: John R Larsen
Subject: [Jailkit-users] [Fwd: Trouble with perl program on Gentoo Linux]
Date: Fri, 17 Mar 2006 12:16:14 -0500

I'm still having the same problem, but I've tried some things in an attempt to 
isolate the problem.  I 
downloaded the sources for perl 5.8.8 and built it locally.  It passes all the 
tests.  I then installed it to 
/usr/local/bin..  Next I used tar to copy the /usr/local/bin, /usr/local/lib, 
and /usr/local/man directories into 
the jail.  This insures that symbolic links and files in the directory trees 
are faithfully copied into the jail.

I still get the same errors when executing the test program in the jail.  The 
fork call declares errors like 
the following:

fork(Can't exec "dirname": No such file or directory at ./test.pl line 12.
)                                  = 11246

The test program works fine when executed outside the jail.

Has anyone else solved similar problems with perl in a jail?


John R Larsen <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]