[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Jailkit-users] sftp not working on Redhat AS3

From: Moriarty, Dan
Subject: RE: [Jailkit-users] sftp not working on Redhat AS3
Date: Sat, 11 Feb 2006 07:41:34 -0800

I've tried using bash and jk_lsh inside the jail with the same results.
I did not intentionally turn off logging for jk_socketd, is there
something I need to do to specifically turn logging on for it?

Dan Moriarty
SJM UNIX Administrator
Ph: (818)493-2775

-----Original Message-----
From: address@hidden
[mailto:address@hidden On Behalf
Of Olivier Sessink
Sent: Friday, February 10, 2006 5:56 PM
To: address@hidden
Subject: Re: [Jailkit-users] sftp not working on Redhat AS3

Moriarty, Dan wrote:
> I'm having a problem with sftp on my Redhat AS3(x86 and x86_64)
> functioning with jailkit version 1.3 as well as the CVS version.
> When I try to connect using SFTP, I am able to connect but immediately
> get a connection closed message as seen from my syslog message:
> Feb  9 17:31:40 ussymes01 sshd(pam_unix)[26578]: session opened for
> booboo by (uid=32770)
> Feb  9 17:31:40 ussymes01 jk_chrootsh[26579]: now entering jail
> /home/sftproot for user booboo (32770)
> Feb  9 17:31:40 ussymes01 sshd(pam_unix)[26578]: session closed for
> booboo
> I've tried to connect using SSH by changing the shell in
> /<jail>/etc/passwd to bash and it does let me connect  and the
> is working so I don't think that it is jk_chrootsh that is causing the
> problem.
> I've used strace to try and find an error but nothing is reported
> either, just the session closed message.

which shell are you using inside the jail? and do you allow logging from
inside the jail to the real system (e.g. with jk_socketd)?


Jailkit-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]