[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Import large amount of files on Windows (but cvsnt has issues)

From: Wurdock, Tom
Subject: Import large amount of files on Windows (but cvsnt has issues)
Date: Mon, 22 Sep 2008 22:55:44 -0500

Hello all,

I have 450,000 files in a folder that need to be imported into cvs.  The
server is linux.  We're migrating from another source control system.

The files were developed on Windows and have windows eol's.  When I try
to import anything "cvs import" I get a bad error:

cvs [import aborted]: received abort signal
cvs: /usr/local/src/cvs-1.11.21-v3/src/import.c:610:
process_import_file: Assertion `entdata->options[0] == '-' &&
entdata->options[1] == 'k'' failed.

That's not even the 450,000 files.  Googling has not explained that

I zipped up a smaller directory and copied it onto a linux box.  I ran
the import there and it worked fine, but I ended up with eol issues when
I checked back out onto windows.  I assumed tht would happen but I
thought just maybe an import would just stick the files in there and
we'd be on our way.  I still have to understand tht issue, but IIRC it's
that the windows checkout ends up with \n's replaced with \r\n (so we
have \r\r\n instead of \r\n)???

So to summarize the windows client blows and I can't just use linux.
How can I check in half-a-million files into cvs?  Scripting a recursive
add-and-commit is also giving me trouble.

Tom Wurdock
Programmer Analyst
PLATO Learning, Inc.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]