[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot connect to remote CVS server

From: John Nichel
Subject: Cannot connect to remote CVS server
Date: Tue, 17 Feb 2004 12:00:06 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

Hello list,

I recently installed cvs 1.11.13 (from source) on a Red Hat 9 box, and am having issues connecting from remote machines. My setup is below...

CVSROOT is set to /webserver/vhosts with these lines in /etc/profile...


Echoing out CVSROOT return this...

>address@hidden CVSROOT]# echo $CVSROOT

The xinetd entry for the cvs server is as such...

>service cvspserver
>        port = 2401
>        socket_type = stream
>        protocol = tcp
>        user = root
>        wait = no
>        disable = no
>        type = UNLISTED
>        server = /usr/local/bin/cvs
>        server_args = -f --allow-root /webserver/vhosts pserver

I have added my login as a user, which created a 'passwd' file under CVSROOT, and contains this...


All is working fine when I use cvs locally, but when I try to connect remotely, I get this....

>cvs -d :pserver:address@hidden:/CVSROOT login
>/CVSROOT: no such repository
>cvs login: authorization failed: server devbox.local rejected access to /CVSROOT for user jnichel

I've also tried with just / as my root, and get the same error. I errors like this on google and the site, and per, I telnet'ed to the cvs server from a remote box, and got the response that the FAQ says I should get if the cvs server is working fine.....

>address@hidden jnichel]$ telnet devbox.local 2401
>Connected to devbox.local.
>Escape character is '^]'.
>cvs [pserver aborted]: bad auth protocol start: foo
>Connection closed by foreign host.

I'm at my wits end.  Can someone shed some light on this?  TIA

It's all about the Rush

reply via email to

[Prev in Thread] Current Thread [Next in Thread]