[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Why can't root check in files?

From: luke
Subject: Re: Why can't root check in files?
Date: Mon, 15 Oct 2001 09:21:58 +1000 (EST)

>  > Using my script it takes 10 mins to put your system under CVS control. 
>  > The learning curve in the simplest case is: 
>  >  
>  >    $ su 
>  >    # cvs-etc 
On 12 Oct, Larry Jones wrote:
>  If you're using su to get to root, then CVS should be able to figure out 
>  your real userid and you should be able to commit.
>  If not, you need to 
>  figure out why getlogin() doesn't work right on your system. 

Today it worked.  ???!

I never log in directly as root; I always su.  How strange.  I'll keep
an eye out and see what happens in the future.  [Added later:  It would
have been because I did an "su -",]

But the other reasons for wanting the commit -u option stand.

Ah, hang on.  I just took a guess at how CVS does it... [Investigates.] 
Okay, that's equivalent to the functionality I was requesting (although
slightly inferior to what I finally suggested - storing e.g. root/luke
in the case where I'm su-ed to root), but it's enough.

I don't understand why no one pointed out you could achieve exactly what
I wanted with CVS as it stands.  I read the other information as
implying it required a source code change and a recompilation.

Thanks, I'll post my cvs-etc script after I've tried it out a little
more, if anyone is interested.

[Note to self: forward this to the list from work on Monday.]


reply via email to

[Prev in Thread] Current Thread [Next in Thread]