[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installing CVS on Red Hat 7.0

From: Harnish, Joe
Subject: Installing CVS on Red Hat 7.0
Date: Mon, 8 Oct 2001 14:52:22 -0400


I am currently trying to get a remote CVS server setup on a Redhat 7.0 system.  What is wanted is for the developers to connect to this central repository with WinCVS and Checkin/Checkout code.  I have gone through the Setup documents and I can not figure out why the cvspserver is not listening.  With Redhat Linux 7.0 I had to change the inetd.conf line into a xinetd.d file which looks like:

service cvspserver
        socket_type             = stream
        protocol                = tcp
        wait                    = no
        user                    = root
        server                  = /usr/bin/cvs
        server_args             = cvs --allow-root=/home/cvsroot pserver
        disable                 = no

The line is in the /etc/services file for cvspserver to listen on 2401 tcp & udp.  I have CVSROOT set in /etc/profile.  After I did that I created a blank file in /home/cvsroot/CVSROOT/ called passwd.  Then I added myself as a user into cvs (using the same password to login to the machine).  Next I ran:  kill -HUP pid.  Replacing pid with xinetd's pid number.  When I run a netstat -ta  --net | grep cvspserver I get nothing.  Is there anything special I need to do?  I think it is something really small that I am missing.

Thanks for any help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]