[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Help-smalltalk] [PATCH] rename Directory>>#contents to #entryNames
From: |
Paolo Bonzini |
Subject: |
[Help-smalltalk] [PATCH] rename Directory>>#contents to #entryNames |
Date: |
Sat, 05 Apr 2008 14:54:00 -0000 |
This is another small step; I separated it to highlight the incompatibility.
Since there will be no File and Directory classes at the end, there was
a clash between File>>#contents and Directory>>#contents.
---
kernel/Directory.st | 2 +-
packages/httpd/FileServer.st | 2 +-
packages/net/URIResolver.st | 2 +-
packages/seaside/core/Seaside-GST.st | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/kernel/Directory.st b/kernel/Directory.st
index 21bb153..9372af8 100644
--- a/kernel/Directory.st
+++ b/kernel/Directory.st
@@ -322,7 +322,7 @@ virtual one).'>
^ws contents
]
- contents [
+ entryNames [
"Answer an Array with the names of the files in the directory
represented by the receiver."
diff --git a/packages/httpd/FileServer.st b/packages/httpd/FileServer.st
index 23e6fc3..ee1dc14 100644
--- a/packages/httpd/FileServer.st
+++ b/packages/httpd/FileServer.st
@@ -111,7 +111,7 @@ A DirectoryResponse formats output of the contents of a
Directory object.'>
nl;
<< '<hr>';
nl.
- (Directory name: file name) contents asSortedCollection
+ (Directory name: file name) entryNames asSortedCollection
do: [:each | self sendFileProperties: each].
self << '</pre><hr><FORM ACTION="' << request uri.
self
diff --git a/packages/net/URIResolver.st b/packages/net/URIResolver.st
index f70de75..593c34c 100644
--- a/packages/net/URIResolver.st
+++ b/packages/net/URIResolver.st
@@ -229,7 +229,7 @@ Copyright (c) Kazuki Yasumatsu, 1995. All rights reserved.
nextPutAll: 'Up to higher level directory</a>';
nl;
nl.
- aDirectory contents asSortedCollection do:
+ aDirectory entryNames asSortedCollection do:
[:name |
| file isDirectory fileSize |
file := aDirectory at: name.
diff --git a/packages/seaside/core/Seaside-GST.st
b/packages/seaside/core/Seaside-GST.st
index f7d3745..0f2e2c9 100644
--- a/packages/seaside/core/Seaside-GST.st
+++ b/packages/seaside/core/Seaside-GST.st
@@ -555,7 +555,7 @@ Object subclass: WAGNUSmalltalkPlatform [
must not include file names that start with ."
| directory |
directory := Directory name: aPathString.
- ^(directory contents
+ ^(directory entryNames
reject: [ :each | each first = $. ])
collect: [ :each | Directory append: each to: directory name ]
]
--
1.5.3.4.910.gc5122-dirty
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- [Help-smalltalk] [PATCH] rename Directory>>#contents to #entryNames,
Paolo Bonzini <=