[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

possible bug in RCS

From: Bostjan Vilfan
Subject: possible bug in RCS
Date: Sat, 13 Jul 2013 15:03:47 +0200

I found the following problem with RCS:

I have a directory (src, see attachment) with a RCS subdirectory. Some
files in RCS have a symbolic name, current, and some of the
corresponding revisions are checked out (and locked). I tried to
execute the command "ci RCS/*,v", and here is what happened

RCS, version 5.7.1: command executes OK

RCS, revision 5.8.1 (cygwin version on Windows 7): program aborts and
the file  ci.exe.stackdump is created (see attachment)

RCS, revision 5.8.1 (on Debian 7): one file is processed (In.cpp),
after which an abort occurs (message: Aborting)

RCS, revision 5.9.0 (on Debian 7): the same result as in the previous

In view of the above, I strongly suspect that the problem in versions
5.8.1  and 5.9.0 is due to a bug. Can someone verify?

Description: Zip archive

Attachment: ci.exe.stackdump
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]