[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: FW: Question Regarding RCS

From: Cannon, Alastair, VF UK, Partner
Subject: RE: FW: Question Regarding RCS
Date: Wed, 24 Feb 2010 18:10:07 +0100


I may be barking up the wrong tree here but depending on your Unix
OS/flavour there *was* a 2 gig limit on files in HPUX. 

As I say - this may be nothing to do with your problem it it may be
worth exploring.



+44 7885511822 


-----Original Message-----
From: address@hidden
[mailto:address@hidden On
Behalf Of Bob Proulx
Sent: 22 February 2010 21:20
To: Hemadri, Satish
Cc: address@hidden
Subject: Re: FW: Question Regarding RCS

Hemadri, Satish wrote:
> We are using RCS in our UNIX server for version control and we are 
> facing problem when working with files more than 2 gigabytes.
> *     Is there any limitation storing file which is more 2 gigs?

I can't recall that I have actually tried it with large files.  In
Unix-speak large files means files larger than the 2G 32-bit signed long
integer limit.  But I also don't recall any specific limitation in the
file format that would prevent it.  I will say that I think it should
work with the addition that if it is shown not to actually work in
practice then I think that would be a bug to be fixed.  Because I think
it should work.

> *     Is there 64-bit RCS Version available that can handle files,
> which are more than 2 Gigs?
> *     Where can I get 64-bit RCS version available to download and
> test.

The GNU Project doesn't generally make binary versions available.  The
GNU Project is all about the source code.  As source there isn't any
specific 32, 64 or even a 36 bit version.  It doesn't get frozen into a
specific binary executable type until it is compiled.  The GNU RCS
source can be compiled into a 64-bit executable just fine.  Also, most
architectures support a 32-bit executable with large file support where
the 32-bit executable can access large files (>2G).  I routinely use the
64-bit GNU rcs distributed with Debian on amd64 machines.

> *     Is there any upgrade to RCS available?

Have you actually tried GNU rcs with a large file and found that it has
not worked yet?  If so please provide the error message.  But it sounds
like you are just asking it if should work or not.

As Aaron noted in the message you quoted there hasn't been any recent
updates to RCS because for the most part no updates have been needed.
RCS is a very mature program and has reached a point in its lifecycle
where stability is requied and no new features are being added to it.
Almost every operating system software distribution provides rcs in its
software repository.  It is generally prevalent everywhere.

In order to get more help please reply back to the mailing list with
more information about your environment.  You say you are using a Unix
server but didn't say what operating system and architecture you are
using there.  It could be any of many available.  The OS itself might
not even support large files.  At the least we would need to know some
basic information about your system.

  $ uname -a

Also include any error messages that you are seeing from the tools.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]