[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Corrupt v file inside a CVS database.

From: Aaron S. Hawley
Subject: Re: Corrupt v file inside a CVS database.
Date: Tue, 07 Aug 2007 14:30:27 -0400
User-agent: Internet Messaging Program (IMP) H3 (4.1.3)

You should probably be using the CVS utilities to access CVS files. There may be incompatabilities between RCS's and CVS's file format.

Consider contacting the maintainers of cvs2svn or of CVS.


Quoting address@hidden:

Hi Guys

I have a cpp file stored in CVS which has become corrupt, there are some
1280 revisions in the RCS .v file and trying to access any of the first
266 revisions throws an error, but I can retreieve any other version.
There are no branches at the point of corruption.

I am trying to convert to use svn using cvs2svn, but this particular file
is in my way. Are there any tools to repair or prune the file in question,
the corruption is about 4 years back in time.

I have tried to manually replicate all the additions and deletions, and
also tried to update the v file to remove the corrupt revisions, but as
soon as CVS tries to open the v file, it throws a fatal exception 11. I
guess the check-in key is some sort of checksum designed to prevent

I hope someone has some ideas for this.

Niels Andersen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]