[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: vc compare with last version differs from rcsdiff

From: Aaron S. Hawley
Subject: Re: vc compare with last version differs from rcsdiff
Date: Thu, 13 Nov 2003 17:41:47 -0500 (EST)

This is more an Emacs question than RCS, and I know little about Emacs,
but I'd use:
``M-x debug-on-entry vc-diff''

then to find out how to use the Emacs debugger try:
 ``C-h b''

This is what I saw in a session:

* vc-do-command("*vc-diff*" 2 "rcsdiff" "/www/htdocs/Files/file.php"
WORKFILE nil "-q" "-r1.4" nil "-c")

so it looks like you should make sure your rcsdiff can handle:

rcsdiff -q -c -r1.4

otherwise, try the emacs list.  perhaps one of the vc-mode authors will
pipe in here though.

On Thu, 13 Nov 2003, Nikiforuk, Kevin wrote:

> I recently installed GNU Emacs 21.2.1 (hppa2.0n-hp-hpux11.00) of
> 2002-08-21 and after making some changes in a file, I tried to compare
> it to the previous version.  To my surprise, I was told that there had
> been no changes since the latest version of the file, which was
> obviously not the case.  To compare, I ran rcsdiff against it
> and it returned a whole raft of output.  Using the ps command I know
> what emacs ran the command
> /usr/bin/rcsdiff -r2.23
> Unfortunately, HPUX truncates the output of ps, so I can't tell if any
> other flags were run.  Is there a way to turn on debugging so I can see
> what emacs runs and figure out why it thinks there were no changes?
> Thanks,
> Kevin

     "Too much use of American power overseas causes the nation to look
      like 'the ugly American'." -- Gov. George W. Bush

reply via email to

[Prev in Thread] Current Thread [Next in Thread]