[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: quoting date strings

From: Steven N. Crane
Subject: Re: quoting date strings
Date: Thu, 15 Feb 2001 11:10:46 -0800 (PST)

Hugh, Colin,

Thanks for the replies. I did try escaping with \'s but that didn't
work either. We use ksh. But I get the same thing with sh and zsh.
I suppose I could load bash and see what happens, but...
I've tried this on Solaris 5.7, HP-UX 10.2, AIX, IRIX, DEC-OSF1.
Same thing everywhere. 

It looks like the shell is either sending quoted items as separate args
or RCS is somehow reparsing the input and tripping over blanks. I wrote
a quick little C program but it worked ok; quoted items were correctly
grouped as a single argument.

Maybe it's the way I built RCS, but that was 5 years ago and everything
else seems to work ok. (I actually noticed this problem a while back and 
ignored it since I didn't use -d. Now I'd like to use it).

Still looking...


- Steven

On Thu, 15 Feb 2001, Colin Brough wrote:

> I don't suppose its any consolation, but your exact command lines work
> fine for me - RCS 5.7 on a Redhat Linux 5.2 box, shell is bash version
> 1.14.7(1). What is your shell? Anything else funny in your
> environment?
> Cheers
> Colin
> ----------------------------------------------------------------------
> Colin Brough                               address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]