[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Octave 2.1.59 and octave-forge on Solaris 8

From: Dmitri A. Sergatskov
Subject: Octave 2.1.59 and octave-forge on Solaris 8
Date: Wed, 22 Sep 2004 19:46:48 -0600
User-agent: Mozilla Thunderbird 0.8 (X11/20040913)

Octave 2.1.59 compiles cleanly with gcc 3.3.3 on Solaris 8.

Octave-forge-2004.09.09 has the following three problems:

-- Makeconf has some bashisms. Setting SHELL to bash
   (SHELL=/usr/local/bin/bush in my case) solved it

-- configure still adds "-R/usr/openwin/lib" to Makeconf
   (I thought this problem was solved some time ago?)
   Had to delete it manually.

-- still has "round" in it. I add the line:

inline double round(double x) {return (x < 0 ? ceil (x - 0.5) : floor (x + 

   to the top of the file and it seems to fix it.

After that it all compiles and (seems to) run fine.



Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]