[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [OctDev] Octave-forge Development (fwd)

From: Tom G. Smith (Smitty)
Subject: Re: [OctDev] Octave-forge Development (fwd)
Date: Fri, 11 Jun 2004 12:32:35 -0500 (CDT)

Perhaps unfortunately, I'm running RH9, and just purchased
RedHat Enterprise Linux AS.  We have a bank of about 20 computers
running under Condor, all at RH9, and that's where we want to
use Octave.  We have a license for MATLAB, but it's only one
concurrent user; that doesn't help us much on the bank running
under Condor.  The researcher I'm working for does some image
processing in MATLAB, and he's hoping he can reduce his turnaround
by converting to Octave and using our bank of computers under Condor.

I get the impression from a number of responses that people think
I've somehow been messing with the source for octave-forge.  I assure
you, all I did was use the commands David Bateman sent me to get the
source for octave-forge, and only started changing things when the
make started failing:

cvs -d:pserver:address@hidden:/cvsroot/octave login
cvs -z3 -d:pserver:address@hidden:/cvsroot/octave co

I'd be happy to compile from source, if that would solve my problems,
but having someone say, for example, "I've just today compiled
CVS checkout of octave-forge on a CVS version of Octave and the
sequence ./; ./configure; make; make install; worked with
no problems what so ever."  I tried that, using the source from
the cvs commands above, and it does not work for me.  I got both
octave 2.1.57 and octave-forge to compile, with the indicated source
changes I've previously indicated, but then I got a "dispatch.oct is
not a valid shared library" message when immediately upon invoking
octave.  I found a message using Google that says I need to compile
shared library support in.  So I started over, using make distclean;
./configure --enable-dl --enable-shared; make; make install, and when
that finished, octave aborted with a segmentation fault immediately
upon invocation.  That's when I decided to try the RPMs, and at least
it runs now, though, as I said, the original problem with delaunayn
being missing still hasn't been solved.

I'm certainly receptive to suggestions, except I don't think changing
over our Linux distribution from RedHat to Debian is a viable suggestion.
If anyone who got octave and octave-forge to compile with no problems
could tell me exactly what source they used, and what commands, I'd
certainly be willing to give it a try.

---------- Forwarded message ----------
Date: Fri, 11 Jun 2004 12:05:36 -0500
From: John W. Eaton <address@hidden>
To: "Tom G. Smith (Smitty)" <address@hidden>
Cc: address@hidden, Ted Tower <address@hidden>
Subject: Re: [OctDev] Octave-forge Development (fwd)

On 11-Jun-2004, Tom G. Smith (Smitty) <address@hidden> wrote:

| I finally got a working octave, but only by using rpms, and even
| then I had to force it it ignore dependencies.  Without --nodeps I
| got this error:
|       error: Failed dependencies:
|               libqhull >= 0:2003.1 is needed by octave-forge-2004.02.12-2mdk
| But, as you can see below, the qhull I was installing *was* >= 2003.1, and
| I haven't located an rpm for a release any more recent than 2003.1-1:

It's unfortunate that there are problems with the RPM files that you
found, but ensuring that the packages for every distribution work
correctly is a bit beyond the scope of the Octave and Octave-forge
projects.  If you want to see the packages fixed, then I suggest that
you report the problems you have with the RPM packages to whoever
built them.

| And after many days of work, I still don't have a solution to the original
| problem, namely that the researcher I'm working for wants to use delaunayn;
| it still comes up missing.

On a current (i.e., testing) Debian system, all you would have to do

  apt-get install octave2.1 octave-forge

and I think you would get a working delaunayn.

So apparently it is possible to build a working version of Octave and

I've not read all the messages you've sent carefully, but it seems
that you have been mixing versions when you have tried to build these
packages yourself.  I don't think it is reasonable to expect that you
can grab any combination of versions and expect perfect results.  For
Debian, Dirk is apparently building Octave 2.1.57 and an Octave-forge
version 2004.02.12.  Minor changes may have been required to get a
clean build, but I don't think it should take major surgery.  I don't
recall precisely what OS/tools you are using, but if the build fails
on your system with these versions of Octave and Octave-forge, then
perhaps you are using the wrong versions of other tools?


This e-mail is intended for the use of the addressee(s) only and may contain
privileged, confidential, or proprietary information that is exempt from
disclosure under law.  If you have received this message in error, please
inform us promptly by reply e-mail, then delete the e-mail and destroy any
printed copy.   Thank you.

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]