[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: downloaded octave from fink and can't start it

From: Christoph Dalitz
Subject: Re: downloaded octave from fink and can't start it
Date: Wed, 9 Jun 2004 16:54:11 +0200

On Wed, 9 Jun 2004 09:29:12 -0500
djanse1 <address@hidden> wrote:
> Thats's what it was...
> I ran into an IT friend of mine this morning on the train and he fixed it for 
> me.
> He said the .profile had . /sw/bin/ in it but didn't execute it when 
> X11 was started up.
> He bypassed it by giving it a second start-up file attached that contains the 
> same information and 
> now it works fine.
> A bit strange to me, but hey it thanks for all your help.
I think you will need to add the option "-l" to xterm command in the X11 startup
items and X11 applications. "xterm -l" starts a "login shell", which forces
~/.profile to be read.

The reason why ~/.profile is not sourced by default is that (unlike X11 on other
Unices) the Aqua GUI is not started as a subprocess of a shell and is thus 
to all entries in ~/.profile. It does read however ~/.MacOSX/environment.plist, 
this file can only set environment variables and cannot source shell scripts 


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]