[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: little things ...

From: John Eaton
Subject: Re: little things ...
Date: Wed, 23 Feb 94 23:30:36 CST

address@hidden (Joseph E. Sacco) wrote:

: I have been doing some alpha testing on glibc-1.07.4[an alpha release :-)]
: so I thought I'd see what I ran into building Octave-1.0. I am using
: gcc-2.58 and libg++-2.5.3 on a SPARC10 running OS4.1.3. 
: The first "surprise" was that the configuration process opted to use
: f2c rather than the unbundled SUN fortran, version 1.4, in stalled
: on the system.  Is that normal?

No, it should probably have decided to use the Fortran compiler.  Was
f77 in your path when you ran configure?  If so, and the configure
script still chooses not to use it, it may be that there is a bug in
the and/or scripts.  If you can determine why
this failure occurs, send a message to address@hidden and
I'll see if I can fix it.

: The second "surpise" was a multuple definition of "_z_abs"; one from
: libf2c.a and the other from libc.a. I got around this by yanking
: z_abs.o from libf2c.a. With this change octave was able to link.

Ok, but this isn't really a bug in Octave, so I'm not sure what I
should do about it.

:     Next I ran the tests in the test directory:

: FAIL:   infnan-4

This test is checking to see what `finite (NaN)' returns.  I think it
should return false and it does on most (all?) other systems.

: FAIL:   npsol-1
: FAIL:   npsol-4

The standard distribution doesn't include npsol because it is not
freely redistributable.  I suppose I should probably not distribute
the npsol tests either, or at least disable them by default.

: I've started looking at some of the examples shown in the info doc.
: Is plot (x,t) supposed to work? The parser complains that it does
: recognize "plot". I have gnuplot installed. The parser recognizes
: "gplot x".

The gplot function is a builtin, but plot is implemented in a .m file.
I suspect that you haven't completely installed Octave, or that the
LOADPATH is somehow wrong, so Octave is unable to find plot.m.

: What about dynamical linking? The config files seem to indicate that
: it's been turned off. It does work on my system ven when using the
: SUN linker although one has to remember to link "statically".

Octave has some hooks to use dld to provide the ability to link
external object files at run time, but it isn't complete yet.  I
haven't tried it in months, and I wouldn't expect it to work now.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]