[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "Unsupported manifest format" error, likely corrupt store

From: Julien Lepiller
Subject: Re: "Unsupported manifest format" error, likely corrupt store
Date: Sat, 26 Nov 2022 22:43:35 +0100
User-agent: K-9 Mail for Android

Don't bother with guix refresh, it's meant for huix devs.

If you have a previous generation of your profile, you could try and switch to 
it (guix package --roll-back), but you said that didn't work. You can also 
switch manually by repeating the steps Guix would take behind the scenes, 

You'll notice that ~/.guix-profile is a symlink to 
/var/guix/profiles/per-user/tyler/guix-profile. It itself is a symlink to the 
current generation, a file such as guix-profile-17-link. Change that last 
symlink to point to the previous generation instead, such as 
guix-profile-16-link. That's all you need to switch generation. Hopefully, that 
generation's manifest is not corrupted.

Le 26 novembre 2022 22:34:11 GMT+01:00, Tyler Wolf via <> a 
écrit :
>Yesterday my PC lost power and when I turned it back on I started getting the 
>error "guix package: unsupported manifest format".
>I have tried using "guix time-machine" to revert to a working commit and try 
>again but this does not work. I have also tried a roll-back.
>I then can see that my ~/.guix-profile/manifest is empty, thus I think it is 
>safe to say that this is where the issue is originating, however I am unable 
>to rewrite this file, so I was wondering if there was any fix to this?
>I have tried everything that I can think of to repopulate this file, running 
>guix pull as well as pulling certain past commits that worked, however nothing 
>is fixing this error. Running pull works without errors, but the problem 
>I think that my store must be corrupt, as if I run guix gc --verify=contents I 
>get a lot of path was modified, expected hash x, got y errors. I have tried 
>fixing this using repair flag for gc but it is unable to repair these.
>I also used the command "guix refresh" and saw that many packages needed to be 
>refreshed, however I cannot finish this command as I get the following error:
>13 (primitive-load "/home/tyler/.config/guix/current/bin/g…")
>In guix/ui.scm:
>2275:7 12 (run-guix . _)
>2238:10 11 (run-guix-command _ . _)
>In ice-9/boot-9.scm:
>1752:10 10 (with-exception-handler _ _ #:unwind? _ # _)
>1752:10 9 (with-exception-handler _ _ #:unwind? _ # _)
>In guix/store.scm:
>661:37 8 (thunk)
>2170:25 7 (run-with-store #<store-connection 256.99 7f411174b7d0> …)
>In guix/scripts/refresh.scm:
>567:14 6 (_ _)
>In srfi/srfi-1.scm:
>634:9 5 (for-each #<procedure 7f411d493340 at guix/scripts/ref…> …)
>In guix/scripts/refresh.scm:
>367:10 4 (check-for-package-update #<package xkbset@0.6 gnu/pac…> …)
>In srfi/srfi-1.scm:
>858:15 3 (any1 #<procedure 7f41202d2da0 at guix/upstream.scm:28…> …)
>In guix/gnu-maintenance.scm:
>842:10 2 (_ _ . _)
>In ice-9/boot-9.scm:
>1685:16 1 (raise-exception _ #:continuable? _)
>1685:16 0 (raise-exception _ #:continuable? _)
>Any help would be greatly appreciated.
>Thanks,Tyler Wolf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]