[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

EFI boot: 'could not prepare Boot variable: Invalid argument'

From: post
Subject: EFI boot: 'could not prepare Boot variable: Invalid argument'
Date: Sun, 06 Nov 2022 12:52:23 +0000

Hi Guix-helpers,

I've just switched to a new system, but as of the 4th generation, guix system reconfigure fails to install the bootloader. This is on guix commit 3e25944 (but that was also the case when guix system reconfigure still worked, I believe). I fear my system is currently unbootable.

The error seems to come from efibootmgr, which complains about
'Could not prepare Boot variable: Invalid argument'

The failing command, if I'm not mistaken, is
/gnu/store/k1z2szmyvi1na7vzv8vnxmpb51nf4aw9-efibootmgr-17/sbin/efibootmgr -c -d /dev/sda -p 1 -w -L Guix -l \EFI\Guix\grubx64.efi.

and I can't find anything wrong with it. I've also tried running the same command with the other version of efibootmgr I could find in /gnu/store, but that results in the same error.

Running efibootmgr gives me the following output:

BootCurrent: 0000
No BootOrder is set; firmware will attempt recovery

which I think implies that my system is currently unbootable?

Does anybody have a guess what can cause this (and what might solve it?).

many thanks!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]