[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing guix on nixos system

From: Roy Lemmon
Subject: Re: Installing guix on nixos system
Date: Thu, 19 Mar 2020 13:17:26 +0000

Hi Marius et al.,

Thanks for your help. That is clearer now. In fact that is what I did, ran
'guix pull' as user and the latest version of guix is installed in

My problem now is that I can run guix from there if I use the full path

$ ~/.config/guix/current/bin/guix --help

But if I just run:

$ guix --help

it doesn't recognise the command. Normally this would just be because I
have not added that directory to PATH as you say.

However here is the problem. I am using eshell in emacs. I have tried the

$ (setenv "PATH" (concat "/home/rlemmon/.config/guix/current/bin:" (getenv
$ addpath /home/rlemmon/.config/guix/current/bin

But still the same problem. I understand this is now an eshell problem
rather than a guix one. But if anyone has encountered this before ... ? Its
a frustrating problem !


On Thu, Mar 19, 2020 at 9:21 AM Marius Bakke <address@hidden> wrote:

> Roy Lemmon <address@hidden> writes:
> > Hi All,
> >
> > I have followed the instructions in that link and successfully installed
> > the build users and guix daemon on my nixos system. As root, I can run
> >
> > guix package -i hello
> >
> > and the hello package is installed and I can run it.
> >
> > However I am having trouble setting up the environment for running guix
> as
> > a user (I am on my laptop, so there is only one user). guix is of course
> > not recognised as a command when I am the user. I can run it as
> > /usr/local/bin/guix so that is ok and I could put that in my PATH. But is
> > that all I need to do ? I am not sure where the guix packages are
> installed
> > as a user rather than root.
> I haven't read the linked blog post, but I think the next step is to use
> the Guix in /usr/local/bin to run 'guix pull' as your user.  That will
> install the latest version of Guix in ~/.config/guix/current.
> Afterwards, make sure ~/.config/guix/current/bin comes first in PATH,
> then you should be able to use Guix normally.

Roy Lemmon
STFC Daresbury Laboratory
United Kingdom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]