[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues building some packages with QEMU binfmt

From: Diego Nicola Barbato
Subject: Re: Issues building some packages with QEMU binfmt
Date: Mon, 09 Mar 2020 23:00:17 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)

Hi Chris,

Christopher Baines <address@hidden> writes:

> Hey,
> For the Guix Data Service, I've noticed some builds getting stuck
> recently. It seems to be when qemu-arm is used to run foreign binaries,
> often grep during the git-minimal tests. Currently it's stuck running
> gcc during the configure phase for the Guix package.
> Attaching strace to the stuck process shows the following output in a
> loop, mmap followed by munmap:
> mmap(0xab897cd96000, 4294901760, PROT_NONE, 
> mmap(0x7ffff0000000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, 
> -1, 0) = 0x7ffff70c1000
> munmap(0x7ffff70c1000, 4096)            = 0
> munmap(0x7ffef0010000, 4294901760)      = 0
> I'm guessing this is probably an issue with QEMU, but I was wondering if
> anyone has seen similar behaviour?

I've experienced the exact same thing: Some months ago I attempted to
build the Guix package for armhf-linux on my x86_64-linux machine
(because there were no substitutes) using the qemu-binfmt service.  I
eventually gave up because it always got stuck (I tried it several
times).  In fact I tried it again today and it got stuck during the
`build' phase running sed.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]