[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Does your printer work with Guix System? Please share!

From: Chris Marusich
Subject: Re: Does your printer work with Guix System? Please share!
Date: Sun, 07 Apr 2019 20:41:41 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Hi all,

Ricardo Wurmus <address@hidden> writes:

> Oh, that sounds painful.

It's sooo painful!  I read a good article while looking for printers:

This statement really resonated with me: "Like most things in life that
you have no control over, you'll be happier if you accept printers for
the janky money pits that they really are."

I'm inclined to agree.  It seems like all "consumer-grade" printers are
designed to fail or become obsolete only a few years after you purchase
them [1].  I couldn't justify spending any significant money on the
printers in the stores I visited, knowing that even if I spent $500 on a
"nice" printer, it would still be terrible, and it would still fail in
only a few years.

So I bought a cheaper one.  I avoided HP because I know they use DRM to
enforce the use of their own ink cartridges.  I favored Brother because
I've heard fewer bad things about Brother regarding GNU/Linux support,
and it seemed like you've had some success with that brand in the past.
In the end, I got a Brother HL-L2390DW, and it works.  Kind of.

I tried a few models and brands in the store using both PureOS (a
FDSG-compliant derivative of Debian) and Guix System.  I must have tried
15 or 20 different "all in one" printers, and they all had scanners, but
I couldn't get a single scanner to work at all, on either distribution.
However, I was able to print well enough using PureOS on the following

* Epson ET-7700
* Brother HL-L2320D
* Brother HL-L2390DW.  This is the one I got.

I decided not to try the ET-7700 with Guix System because I decided I
rarely need to print in color (I'll go to a print shop for that), it was
more than I preferred to pay, and its scanner function didn't work even
on PureOS.

I decided to focus on Brother models because they were relatively
inexpensive laser printers.  My understanding is that laser printers
tend to last longer than inkjet printers, and it's more likely that you
can replace the toner with inexpensive third-party toner.  I expect the
printer to fail in 3-5 years, and after that I'll find another.  That's
not great for the environment, but unfortunately I've found no
"consumer-grade" printers with a longer expected lifetime.  At least
it's better than the 2-3 years I'd probably get with an inkjet printer.

I decided to get the Brother HL-L2390DW instead of the HL-L2320D because
it was only $20 more, and it came with a scanner.  The main difference
between the two is the wireless connectivity (that's the "W" in the
name) and the scanner.  The scanner doesn't work with PureOS or Guix
System, but I couldn't find any scanner that did work, anyway.  I'm
hoping that maybe someday I can figure out how to use the scanner with
some FSDG-compliant system, hopefully even Guix System.  A side project
to work on some day...

I tried using the HL-L2390DW in a variety of different configurations in
both PureOS and Guix System.  In short, IPP (over the network, not USB)
delivered the best results.  In the CUPS web UI (https://localhost:631),
in the Administration tab, when you click on "Add Printer", the
HL-L2390DW shows up under "Discovered Network Printers".  The CUPS web
UI automatically fills in the connection details and selects "IPP
Everywhere (tm)" as the model, so you can basically just stick with the
defaults when you add the printer.  When finished, you may want to set
various default options, and you may want to set the printer as the
system default.  In my case, I configured the printer to use duplex mode
(i.e., double-side printing) and to print in US Letter format.  You can
do all of this using the CUPS web UI.  This was relatively easy to do in
both PureOS and Guix System.

I tried printing various documents using various programs.  I tried
printing the default CUPS test document from the web UI, a PDF from
Evince, and the same PDF using the "lp" command line tool.  These test
documents include text and pictures.  When using IPP (i.e., the printer
added as described above), PureOS always printed correctly.

However, even when using IPP, on Guix System there were problems.  When
I printed the CUPS test document from the CUPS web UI, the printer
printed the same document on two sides of one piece of paper, and one
more time on a second sheet of paper.  I expected it to print on both
sides of only one sheet of paper, which is what it did when I tried the
same thing on PureOS.  In addition, the pictures did not print - only
the text and the border of the CUPS test document were printed
correctly.  The same thing happened when I tried to print out my PDF
file from Guix System: the print-out was missing some pictures, but all
other text was printed correctly.  This is good, since it means it's a
problem with Guix System, not the printer.  It isn't possible to fix the
printer, but it is possible to fix Guix System.  For now, I'm going to
print from PureOS until I can figure out what's wrong on Guix System.

I discovered another problem with brlaser that was not specific to Guix
System.  When I added the printer over USB using the brlaser driver (for
the HL-L2300D series), I observed similar results as with IPP: PureOS
printed pictures and text, while Guix System only printed text.
However, there were more problems.  In both PureOS and Guix System, the
bottom border of the CUPS test page was clipped off, as if the brlaser
driver had incorrectly shifted the vertical position of the document by
a few millimeters, or as if it had simply forgotten to draw the very
bottom of the page.  And mysteriously, when I tried to print my test
PDF, it consistently failed to print, causing the printer to display
"Out of memory" on its LCD panel.  Perhaps this is an indication that
brlaser was incorrectly sending tons of data to the printer.  This "Out
of memory" problem did not occur with all PDFs, but I was able to
trigger it with a few different PDFs, so it must be a bug that is
somehow related to the structure of those PDF files.  A mystery to be
solved upstream...

I tried a lot of other configurations: AppSocket, LPD, and so forth.
IPP delivered better results in every case.  For some reason, PureOS was
able to discover more network print servers (e.g., for LPD) than Guix
System, which discovered only the IPP server.  And finally, judging by
the output of "avahi-browse -avr", it seems that the Brother HL-L2390DW
does not advertise an IPPS server, so it probably doesn't support TLS,
which is unfortunate.  CUPS supports IPPS, so if I could use the printer
with the brlaser driver over USB, I could make the printer securely
available in my network via CUPS.  However, since the brlaser driver
doesn't work so well for me on both PureOS and Guix System, this option
isn't very practical for me at the moment.

None of the other printers I tested were any better, even on PureOS.
And some of them cost $300, $400, $500...  I'm satisfied with my
inexpensive, terrible Brother HL-L2390DW, but only barely.  My one
remaining hope is that when this little gremlin gives up the ghost in
3-5 years, there will be better options available.

Thanks for reading so far.  Hopefully someone out there will find this
information useful.  Should I open a bug report for the IPP problem in
which Guix System doesn't print pictures, even though it prints text?



Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]