[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 14.1 Building from Git

From: Giovanni Biscuolo
Subject: Re: 14.1 Building from Git
Date: Mon, 18 Mar 2019 11:08:58 +0100

Hi mikadoZero,

mikadoZero <address@hidden> writes:

> I am trying to follow the instruction in the Contributing section of the
> manual, as I want to submit some patches.  Following "14.1 Building from
> Git" I am getting an error when running `./bootstrap`.

I'm also learning to build from git but I never had such problems with

I'll try to reproduce your bug...

> `guix describe`
> guix 19c0cdb
>     repository URL:
>     branch: master
>     commit: 19c0cdb9e6271956015232421ef7f63a1ad001ae

AFAIU it does not matter what Guix version is in your user profile since
following "7.2 Running Guix Before It Is Installed" you will «test the
changes made in your local source tree checkout without actually
installing them. So that you can distinguish between your “end-user” hat
and your “motley” costume.»

so in this case is useful to show your "git describe" and not "guix

--8<---------------cut here---------------start------------->8---
address@hidden: git describe
--8<---------------cut here---------------end--------------->8---

AFAIU that means: version 0.16.0 and 3520th commit, current commit
"c0d43f6223" (I miss the meaning of g before c0d43f6223)

that is: my “motley” costume will use c0d43f6223 for development

compare it with my current guix version (used by my end-user costume):

--8<---------------cut here---------------start------------->8---
Generation 5    Mar 16 2019 13:09:52    (current)
  guix 703a095
    repository URL:
    branch: master
    commit: 703a095e7ec3c8247deb527f027615e5e34fe753
--8<---------------cut here---------------end--------------->8---

> Here is what I am doing that leads to the error.
> `git clone`
> `cd guix`
> `guix environment guix`
> Then I run `./bootstrap` and it gives me this error output:

I did it again (it's the third time I run ./bootstrap in my dev
environment) and it succeeded with no errors


> error: possibly undefined macro: PKG_CHECK_MODULES
>       If this token and others are legitimate, please use m4_pattern_allow.
>       See the Autoconf documentation.

this error is documented in "7.1 Building from Git" (where did you get
14.1 numbering in the subject?) and the solution is described there also

anyway I don't understand why this happens in a "environment guix"

I'm in this environment

--8<---------------cut here---------------start------------->8---
address@hidden: env | grep GUIX_ENV
--8<---------------cut here---------------end--------------->8---

in this environment ACLOCAL_PATH is defined as

--8<---------------cut here---------------start------------->8---
address@hidden: env | grep AC
--8<---------------cut here---------------end--------------->8---

AFAIU in "environment guix" all needed devel tools should be installed
and related evironment variables set up

are you sure you are running "./bootstrap" in the environment?




Giovanni Biscuolo

Xelera IT Infrastructures

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]