[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [video repo] when making videos inside container images break

From: Gábor Boskovits
Subject: Re: [video repo] when making videos inside container images break
Date: Sun, 3 Mar 2019 20:30:51 +0100

Hello Laura,

Laura Lazzati <address@hidden> ezt írta (időpont: 2019.
márc. 3., V, 20:09):
> > You can go ahead with that. I am busy here tracing down this bug.
> > I got strace for both of inside and outside the container, and it seems
> > that in the container the wrong pixbuf loader is picked up, namely xmp
> > instead of png.
> Sorry, so if you make the video "the hard way" -video by video and
> gluing-, the issue disappears? it has to do with the cointainer then?
> >

Yes, the container misses cairo. Could you try adding at, and see if
the problem persists?

How did I found it? (for myself and for future reference)

I identified that the problem is that the container misses something.
All work fine, if you don't specify the -C option.

Then the hard thing was to find out, what that something was.

I straced the thing in the container, and also did that with the working one,
outside the container.

The svg file was opened quite at the end, and I looked at the trace
from that point on.
It turned out that the image is tried to be opened as xpm... not as
png, as it should be.

Then I looked at the inkscape source, for quite a while...
The good thing to search for turned out to be Inkscape::Pixbuf, which
lead me to find that
inkscape uses cairo in concert with pixbuf.

Then I looked around the package definition of inkscape, where I found
no sign of cairo...

I tried adding it to the container, and it seems to be working fine here.

> > Best regards,
> > g_bor

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]