[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Application Setup on Trisquel

From: Caleb Herbert
Subject: Re: Application Setup on Trisquel
Date: Fri, 10 Nov 2017 15:29:01 -0600

On Thu, 2017-11-09 at 13:05 -0800, Chris Marusich wrote:
> This sounds very similar to
> in which the interaction between Guix-installed packages (emacs, in my
> case) and the XDG_DATA_DIRS environment variable caused the UI
> (including icons) to display incorrectly.  It would be nice to solve
> this in general for Guix-installed applications on foreign distros.  Do
> you have any ideas about how we can solve it?

I don't know how to solve it, but I tried what was done in that post,
and it seemed to help.

        env -u XDG_DATA_DIRS icecat &
        env -u XDG_DATA_DIRS youtube-dl-gui &
IceCat looked much better:

youtube-dlG, however, looked the same:

> "/usr/share/" entry from XDG_DATA_DIRS.  You were able to solve your
> problem by adding ${HOME}/.guix-profile/share to the front of XDG_DATA_DIRS
> and adding the foreign distro's XDG_DATA_DIRS (including "/usr/share/"
> to the end).  I feel like these clues are pointing to something, but I'm
> not yet sure what.  Do you have any good ideas?

You'd have to ask ADFENO.  I didn't think too much about the changes I
made to my system.  I just looked at his instructions, determined if
they were harmless, and followed them.

> displayed icons, locales, etc.) .  However, asking users to configure
> XDG_DATA_DIRS seems significantly more complicated, due to problems like
> these, and also like bug 26202:

I agree.  I'm just a luser.  I don't have a spare system to do
experiments on, and I don't want to be doing experiments on my only

> > Remaining hurdles:
> >       * Buttons don't show up, themes don't match:
> >
> Could this be the same issue that I saw with emacs?


> >       * Fcitx Mozc input method for Japanese does not work in Guix apps
> Can you tell us more about your use case?  Are you trying to install
> fcitx etc. via Guix, and then use it to type in Japanese within
> Guix-installed applications (do they use GTK, or something else)?  

No.  I tried doing that, and Fcitx wouldn't run properly because it
didn't like the fact that Trisquel had its own ibus running.

> Or
> did you install fcitx etc. using the foreign distro's package manager
> (e.g., apt-get), and now you are trying to use that IME to type in
> Japanese within Guix-installed apps?  

Yes, this is what I did.

        sudo apt install fcitx fcitx-mozc

I can type Japanese in Trisquel apps, but not in Guix apps.

Also, Trisquel's Fcitx will let me type Japanese but not any other
language.  Greek is available, but I still get "aoeu" when I switch to

> The interaction between an IME and
> its environment is tricky to get right and depends on a lot of factors,
> so I expect it might require a non-trivial amount of work to make it so
> that all Guix-installed apps will correctly make use of an IME that is
> installed and managed by the foreign distro.

I would gladly use Guix's Fcitx, because its Mozc is newer and lets you
type もも  (momo, "peach") to get 🍑 (":peach:").  But, as mentioned
above, it doesn't play nice with Trisquel's ibus.

> FWIW, I have been able to get Japanese input working in GuixSD in all
> apps using ibus and ibus-anthy.

##japanese on Freenode says Anthy is abandoned, so they recommend Fcitx.

Re GuixSD, I should take the hard drive out of my old laptop and install
GuixSD to try it out.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]