[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GuixSD + GNOME + Wacom Tablet = No tablet detected?

From: Ludovic Courtès
Subject: Re: GuixSD + GNOME + Wacom Tablet = No tablet detected?
Date: Thu, 07 Apr 2016 22:44:00 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

Chris Marusich <address@hidden> skribis:

> address@hidden (Ludovic Courtès) writes:
>> I think the problem is that our xserver.conf does not include
>> xf86-input-wacom to its search path; see (gnu services xorg).
>> Could you try adding it there and reconfiguring from tree (using
>> ‘./pre-inst-env guix system reconfigure’)?
> I've tried that (see attached patch).

The patch looks good to me.

> When I rebooted, the behavior was the same.

Side note: you could have avoided a reboot by doing

  sudo herd stop xorg-server

right before ‘guix system reconfigure’, which would have started the new
‘xorg-server’ service.

> I also tried adding both "libwacom" and "xf86-input-wacom" to the
> globally installed packages, but that didn't work, either.
> There are messages in the Xorg.0.log file.  However, these messages give
> no indication about why I'm seeing the "No tablet detected" error when
> viewing GNOME's "All Settings" > "Wacom Tablet".
> /var/log/Xorg.0.log:[    11.922] (II) config/udev: Adding input device Wacom 
> Intuos3 4x6 Pen (/dev/input/event6)

The log suggests that X detects it.  Is there a chance GNOME would do
something special, like disabling one of the input devices?  Could you
check with a bare-bones window manager whether the tablet is usable?

I have no experience with tablets, so I’m afraid it’s a shot in the


reply via email to

[Prev in Thread] Current Thread [Next in Thread]