[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] Compiling on Fedora 4

From: Chelton Evans
Subject: Re: [Help-gsl] Compiling on Fedora 4
Date: Mon, 10 Jul 2006 23:12:22 -0700 (PDT)

Hi Brian,
 it did not compile because it could not find the
 library. Usually $make install copies them to
/usr/lib.  When I copied the files and put the path 
 in myself (/usr/local/include/gsl) it all worked.  So
the issue was not one of compiling C++ but finding
where the object files were.

I did not track down where the error occured in the
Makefile. While I have looked at the Makefile it 
 appears to me to be complex. I have attached
 my Makefile just in case you need it.
 I run a bash shell.  If I knew more about
 unix I would have tracked it down, perhaps the
 error is on my box only if other people using 
 Fedora 4 do not have this problem.  

from Chelton Evans

--- Brian Gough <address@hidden> wrote:

> At Wed, 5 Jul 2006 06:00:56 -0700 (PDT),
> Chelton Evans wrote:
> > address@hidden gsl]$ gcc -Wall t1.cpp -o main
> -lgsl
> > -lgslcblas -lm
> > /tmp/cc6P8NXu.o(.eh_frame+0x11): undefined
> reference
> > to `__gxx_personality_v0'
> > collect2: ld returned 1 exit status
> Hello,
> GSL should compile on Fedora--not sure why it did
> not work for you.
> If you are compiling a C++ program (t1.cpp) you need
> to use g++
> instead of gcc to avoid the error abovqe.  See my
> gcc tutorial book for
> details
> -- 
> best regards,
> Brian Gough
> (GSL Maintainer)
> Network Theory Ltd,
> Commercial support for GSL ---

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

Attachment: Makefile
Description: 402397780-Makefile

reply via email to

[Prev in Thread] Current Thread [Next in Thread]