[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] XCode and GSL

From: Daniel J Farrell
Subject: Re: [Help-gsl] XCode and GSL
Date: Wed, 28 Jun 2006 00:23:46 +0100

Hi George,

You said is has found your gsl_sf_bessel.h file, so what error message is Xcode giving you now?

As long as the Header Search Path, Library Search Paths and Other Linker Flags have the correct values this should work. If they do and this still doesn't work you might want to consider a reinstall from fink or darwinports?

Regards, Dan.

PS. Have you checked to see what files are in the supposed location. (i.e. with the terminal)? PSS. Yes, DawwinPorts is just as easy as Fink to use. You simply go to the terminal and type:

sudo port install gsl

Come back in a few hours and you'll be up and running.

On 26 Jun 2006, at 23:20, George Japaridze wrote:

Have installed from HMUG web page (Huntsville macintosh users Group). Works fine within a terminal. Have no idea about Darwin Ports - is this easy to use? Have used FINK extensively (except GSL) and no
complaints whatsoever.
I tried Martin's way - still gives a problem, but another one. XCode founds/links gsl_sf_bessel.h, but, in this file there are other header files, e.g. gsl_mode.h - like "#include gsl_mode.h". So, gsl_sf_bessel.h is found, but I need to figure out how to make XCode to get to all the header and lib files. I included my include lib paths in my .bashrc - still no good.
Don't know...
On Jun 26, 2006, at 6:05 PM, Daniel J Farrell wrote:

Yeah that looks like the problem.

I guess you have installed this with fink? How do you find the stability? I installed mine with Darwin Ports (build from source) and don't have an complaints.

Although this is probably off topic what is peoples experience with fink vs. darwin ports?


PS for future darwin port installations have a look here:

On 26 Jun 2006, at 17:04, Martin Jansche wrote:

On 6/26/06, George Japaridze <address@hidden> wrote:

        - Header Search Paths - /usr/local/include/gsl
#include <gsl/gsl_sf_bessel.h>
comes out with error message: "error: gsl/gsl_sf_bessel.h: No such
file or directory",

My guess is the setting of Header Search Paths is wrong. What is the
full path to gsl_sf_bessel.h?  If it's
/usr/local/include/gsl/gsl_sf_bessel.h, then you'd have to set Header
Search Paths to /usr/local/include.

-- mj

Help-gsl mailing list

********************************************************************** ********************* Dr. George Japaridze CTSPS, Clark Atlanta University

address@hidden 404 880 6420 Office           404 226 3847 Cell

reply via email to

[Prev in Thread] Current Thread [Next in Thread]