[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub2 mdadm and default_layout , attempt to read or write outside of dis

From: Darko Luketic
Subject: grub2 mdadm and default_layout , attempt to read or write outside of disk
Date: Sat, 4 Jun 2022 13:25:43 +0200
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Thunderbird/91.10.0


I have made a forum post at if you'd like to read that, but I'll repeat here.

Essentially, I'm getting a

|attempt to read or write outside of disk 'hd1'.|
||when trying to 'linux /boot/the-kernel with-params...'

I have tried:
mdadm --stop /dev/md0
mdadm --assemble -U layout-alternate /dev/md0 /dev/sda2 /dev/sdb1
sure enough when checked with mdadm --detail it shows "layout: alternate"

But I'm guessing grub2 is trying to read hd1, whatever hd1 may be.

I have an external SSD drive via USB, when it's plugged in the error message reads 'hd1', when not it's 'hd0'.

fsck.ext4 returns no errors.

doing ls in grub cli when about to boot shows (md/0) (hd0) (hd1) etc...

A loss of the rootfs would be catastrophic as I've left my usual residence and am in a different country and all the vpn info is there, and hell I really don't have the time to reinstall and reconfigure the system. Lucky /home is separate. I could probably create a /boot partition on the Windows drive (dual-booting) and that's probably what I'll do, because I need to work and I need to access my home network,
but it worked before, why doesn't it now?

I would post the grub.cfg but Windows 10 can't read ext4 by default, afaik. But nothing really changed. My guess is grub can't deal with mdadm's layout-original or layout-alternate or layout-unspecified.

What can I do to solve the problem?

Thanks in advance for eventual responses, please also reply directly as I'm not subscribed to the mailing list.

- Darko

reply via email to

[Prev in Thread] Current Thread [Next in Thread]