[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Loading pcmemtest on UEFI

From: Andrei Borzenkov
Subject: Re: Loading pcmemtest on UEFI
Date: Thu, 2 Sep 2021 10:57:28 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0

On 02.09.2021 02:25, Gordon Messmer wrote:
> I'm trying to load PCMemTest on a UEFI Fedora system.
> After placing the binary on the ESP, I'm able to create an entry with
> efibootmgr to load it directly from the UEFI boot menu, and it works as
> expected, so I'm certain that the binary is "good".
> However,  I haven't been able to load the program from GRUB
> successfully.  The program's documentation says that it supports the
> UEFI handover boot protocol, and I've tried loading it using "linux
> /<path>/pcmemtest.efi", which doesn't seem to do anything.  As far as I
> can tell, the system halts.  I've also tried chainloading the binary,

You should always show exact command(s) you used, not describe it.

> and when that entry is selected, GRUB immediately returns to its menu.

I briefly tried pcmemtest from
with grub 2.06 (openSUSE Tumbleweed) and it runs after

chainloader (hd0,gpt1)/pcmemtest.efi

or menu entry with

chainloader (hd0,gpt1)/pcmemtest.efi

> Does anyone have any basic hints for me at this point, either things
> that I should try, or anything that might tell me what's happening after
> the handover?
Are you sure your grub binary supports chainloader command in the first
place? Signed grub images do not include every possible grub module and
disable external module loading.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]