[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Loading pcmemtest on UEFI

From: Gordon Messmer
Subject: Loading pcmemtest on UEFI
Date: Wed, 1 Sep 2021 16:25:15 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.11.0

I'm trying to load PCMemTest on a UEFI Fedora system.

After placing the binary on the ESP, I'm able to create an entry with efibootmgr to load it directly from the UEFI boot menu, and it works as expected, so I'm certain that the binary is "good".

However,  I haven't been able to load the program from GRUB successfully.  The program's documentation says that it supports the UEFI handover boot protocol, and I've tried loading it using "linux /<path>/pcmemtest.efi", which doesn't seem to do anything.  As far as I can tell, the system halts.  I've also tried chainloading the binary, and when that entry is selected, GRUB immediately returns to its menu.

Does anyone have any basic hints for me at this point, either things that I should try, or anything that might tell me what's happening after the handover?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]