[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: New Grub2 verses Debian 9.5 -boots slow and strange?

From: Pascal Hambourg
Subject: Re: New Grub2 verses Debian 9.5 -boots slow and strange?
Date: Fri, 19 Oct 2018 00:11:15 +0200
User-agent: Mozilla/5.0 (X11; Linux i686; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

Le 18/10/2018 à 22:26, address@hidden a écrit :

On Thu, 18 Oct 2018, Pascal Hambourg wrote:

Le 18/10/2018 ? 21:24, address@hidden a ?crit :

On Thu, 18 Oct 2018, Pascal Hambourg wrote:

run update-grub after the system is started.
That said, I found no grub-update command in this version??
update-grub, not grub-update.

     I tried grub-install --force /dev/sdb but with no effect.

Of course not. The wrong root= parameter is in /boot/grub/grub.cfg. grub-install does not touches this file.

    Tried install-grub - didn't include Debian 9 in the grub boot menu??

Can't your read properly ? For the last time, the proper command is *update-grub*. Not grub-update, grub-install, install-grub or whatever your imagination may invent...

    Started over.

    Booted from grub2 memory stick.

    Debian 9 started OK.

    Ran update-grub2.

update-grub2 is just a symlink to update-grub.

    Ran grub-mkconfig.

Useless if you don't redirect the output tot /boot/grub/grub.cfg, and redundant with update-grub if you do.

    SD now boots :). Nice that it boots. Very strange and slow boot?

What do you mean ? What is strange and slow ?

IME SD card and USB flash drive access from the BIOS can be quite slow, until the kernel and initramfs are loaded.

   Also, there is no need to try to boot anything except this SD since I plug in this SD I want to boot Debian 9.5. I guess I need to edit something? /boot/grub/grub.cfg makes sense, but says not to edit it and it is not obvious what to edit in the files referenced by grub.cfg.

What do you mean ? The boot menu shows other systems than the one installed on the SD card ? This is because of os-prober. Either uninstall os-prober or edit /etc/default/grub and add


to disable it, and run update-grub again in both cases.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]