[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Debian live .iso

From: hoan
Subject: Re: Debian live .iso
Date: Sun, 8 Apr 2018 22:00:40 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.7.0


was loaded with bootia32.efi ;you can try
qemu-system-x86_64  -m 1G -enable-kvm -bios OVMF32.fd debian-8.10.0-i386-lxde-CD-1.iso
it presents splash menu for install !!!!!!
On 08/04/2018 14:15, Narcis Garcia wrote:
My only problem was that Debian seems to read "findiso" parameter
instead of "iso-scan/filename" as Ubuntu does.

Now I boot Live .ISOs from GRUB2: Debian 7, Debian 8 and Debian 9.

Debian 6 not. After a minute says:
live-boot will not start a shell. The error message was:
Unable to find a medium containing a live file system

I've tried also with debian-8.10.0-i386-lxde-CD-1.iso (not Live: only
installer) but DebianInstaller says "No common CD-ROM drive was
detected" and asks for loading CD-ROM drivers or select CD-ROM module
and device (noone is accepted).

El 05/04/18 a les 16:26, hoan ha escrit:
here are 2 examples proved to boot on any laptop

menuentry "debian-live-8.4.0-amd64-lxde-desktop_poorinstalled_sda6" {
        search -f -s /Users/debian/debianLXDE
        linux /Users/debian/live/vmlinuz live-media-path=/debian/live
rootfstype=ext4 boot=live components
        initrd /Users/debian/live/initrd.img
menuentry "debian-live-9.3.0-amd64-cinnamon.iso" {
        set isoloop=/iso/debian-live-9.3.0-amd64-cinnamon.iso
        search -f -s $isoloop
        loopback loop $isoloop
        linux (loop)/live/vmlinuz-4.9.0-4-amd64 findiso=$isoloop
rootfstype=iso9660 boot=live components systemd.debug-shell=1
systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M
        initrd (loop)/live/initrd.img-4.9.0-4-amd64

ex 1 the debian_lxde is simply extracted from file.iso into directory

ex 2 is genuine loopback on file.iso sitting at root of any partition

The reason why you failed is due to "set root=(loop)" ;on booting grub
sees (loop)/live/vmlinuz + options, loads initrd.img

but once grub gives hands to kernel_vmlinuz in kernel space (loop) has
no meaning as well as $(loopback) neither $(loop)

option findiso for debian init_space looks for $isoloop (the pristine
reason to find isoimage where it seats, and try to boot after)

you can forget the whole option systemd related for ...learning in
details about debian booting



On 05/04/2018 09:59, Narcis Garcia wrote:
Has anybody reached to boot a Debian ISO image?
For example, installing GRUB2 on a USB stick with .iso files.

I've tried this with no luck:

submenu "debian-live-9.4.0-amd64-gnome.iso" {
      search --set=root --file $iso_path
      loopback --delete loop
      loopback loop $iso_path
      menuentry "Debian GNU/Linux Live (kernel 4.9.0-6-amd64) [grub]" {
        linux  /live/vmlinuz-4.9.0-6-amd64 boot=live components
        initrd /live/initrd.img-4.9.0-6-amd64

Results in:

[...] ... mounted filesystem...
[...] random: crng init done
Busybox ...
(initramfs) Unable to find a medium containing a live file system

Help-grub mailing list
Help-grub mailing list
Help-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]