[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

6.3 Multi-boot manual config seem doomed to fail

From: Felix Miata
Subject: 6.3 Multi-boot manual config seem doomed to fail
Date: Sun, 24 Dec 2017 01:54:22 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 SeaMonkey/2.49.1

Based on the example "menuentry "OS using grub2-legacy"" there, & on account of
"video= on kernel cmdline ignored when loaded by grub2"
which is not applicable to Tumbleweed or 15.0, I'm trying to use openSUSE's Grub
0.97-210.3 to start 42.3 to see if it amounts to a workaround. This is the
applicable grub.cfg stanza:

        menuentry "Chainload to Grub in /dev/sda3" {
            insmod ext2
            search --set=root --label gb3203usrlcl --hint hd0,gpt3
            legacy_configfile /grub/menu.lst

Trying, I get these messages:
error: could not load file /boot/vmlinuz.
error: you need to load the kernel first.

Grub efi version producing the failure is Debian Stretch's 2.02~beta3-5.

Actual content of /grub/menu.lst on the EXT3 gpt3 partition containing
openSUSE's Grub 0.97:

        color cyan/blue white/blue
        default 0
        fallback 1
        timeout 33
        gfxmenu (hd0,2)/grub/message

        title openSUSE 42.3 defkernel on sda9
            root (hd0,8)
            kernel /boot/vmlinuz showopts root=LABEL=gb3209s423 ipv6.disable=1
net.ifnames=0 noresume vga=791 address@hidden address@hidden 3
            initrd /boot/initrd

The entirety of /grub/ on gpt3 is replicated on gpt9 in /boot/.

While booted to 42.3 on gpt9 I ran 0.97 setup against gpt3, as I've been in the
habit of doing with MBR installations for well over a decade[1], and received no
unexpected error messages. [ root (hd0,2); setup (hd0,2) ] The usual two
failures to embed stage1_5 occurred.

Kernel/initrds I want to load are in /boot/ on gpt9.

Usual mount point of gpt3 is /usr/local/.

Using edit mode, I've tried replacing the runtime translated result of 'root
(hd0,8)' variously to:


The runtime translation displays the following on screen in edit mode:

        set root='(hd0,9)'; set legacy_hdbias='0'
        legacy_kernel /boot/vmlinuz' '/boot/vmlinuz' 'showopts' 
'ipv6.disable=1' 'net.ifnames=0' 'noresume' 'vga=791' 'address@hidden'
'address@hidden' '3'
        legacy_initrd '/boot/initrd/' '/boot/initrd'

I'm unable to locate any documentation explaining "legacy_hdbias='0'".

Partitions are as follows:
# gdisk -l /dev/sda
GPT fdisk (gdisk) version 1.0.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 625142448 sectors, 298.1 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 5A35...
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 625142414
Partitions will be aligned on 2048-sector boundaries
Total free space is 510208621 sectors (243.3 GiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          657407   320.0 MiB   EF00  gb32 EFI System (ESP)
   2          657408         5375999   2.3 GiB     8200  gb32 P02 Swapper
   3         5376000        10078207   2.2 GiB     8300  gb32 P03 /usr/local
   4        10078208        23185407   6.3 GiB     8300  gb32 P04 /home
   5        23185408        55953407   15.6 GiB    8300  gb32 P05 /pub
   6        55953408        70699007   7.0 GiB     8300  gb32 osTW P06
   7        70699008        85444607   7.0 GiB     8300  gb32 os150 P07
   8        85444608       100190207   7.0 GiB     8300  gb32 Debian Linux 9...
   9       100190208       114935807   7.0 GiB     8300  gb32 os423 P09

Before trying Grub2 "multi-boot"[2] I tried Grub2 chainloading[3][4] to gpt3's
Grub Legacy, but no matter what I tried I got "invalid sector size 65535" and
was unable to find an explanation how to fix it, all search hits pointing to
Windows rather than FOSS partitions.

Am I trying to do the impossible? If not, what do I need to do?

[4] <>
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***

reply via email to

[Prev in Thread] Current Thread [Next in Thread]