[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

MacBook net_bootp Issues

From: Daniel Pedigo
Subject: MacBook net_bootp Issues
Date: Thu, 26 Oct 2017 15:18:51 -0600

Hoping someone can point me in the right direction as I'm having spotty
success jumpstarting the network boot process on some macs. In particular it
seems to be the newer devices.


I'm using the latest code from the master branch (shows version 2.03). The
device I've been testing with is a MacBook Pro A1707. I've tried a couple of
different brands of USB-C to ethernet adapters and I get the same behavior
with each. The USB adapter is showing up as efinet1 and when I run the
command `net_bootp efinet1` I get back 'error: couldn't send network


Now I've debugged it a bit and ultimately it fails in send_card_buffer (line
74) with the call to transmit. The error code returned from net->transmit is
12 (GRUB_EFI_NO_MEDIA). Yes, the cable is plugged in. :) 


So far, of the things I have tried, the only thing that actually works on
occasion is to unplug the adapter and plug it back in. I've fiddled with
resetting the SNP service and reopening it without any difference-but I'm
really just taking stabs in the dark over here. I have looked at the bug
database and the only one that stood out was and while there is some similarity, the
end result is different. I applied the attached patch anyways and the issue
persisted all the same so I reverted those changes.






reply via email to

[Prev in Thread] Current Thread [Next in Thread]