[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

no suitable video mode found

From: YuGiOhJCJ Mailing-List
Subject: no suitable video mode found
Date: Tue, 12 Sep 2017 05:59:04 +0200


I am using GRUB 2.02 built from source code.

This is my /boot/grub/grub.cfg file:
# /boot/grub/grub.cfg
set timeout=0
set default=0
#set gfxpayload=text
menuentry "Linux 4.9.24" {
        linux /boot/vmlinuz root=/dev/sda1 ro

When I run my machine I get:
error: no suitable video mode found
Booting in blind mode

So, I tried to set gfxpayload to 'text' but I got:
error: no suitable video mode found
invalid video mode specification `text'

So, I am unable to use GRUB on my machine.

Here is the cut configure output:
$ CFLAGS="-O2" CXXFLAGS="-O2" ./configure --prefix=/usr --libdir=/usr/lib64 
--sysconfdir=/etc --with-platform=efi --target=x86_64 --program-prefix=
GRUB2 will be compiled with following components:
Platform: x86_64-efi
With devmapper support: Yes
With memory debugging: No
With disk cache statistics: No
With boot time statistics: No
efiemu runtime: No (not available on efi)
grub-mkfont: Yes
grub-mount: Yes
starfield theme: No (No DejaVu found)
With libzfs support: No (need zfs library)
Build-time grub-mkfont: No (no fonts)
Without unifont (no build-time grub-mkfont)
With liblzma from -llzma (support for XZ-compressed mips images)

As you can see, there are some disabled features but I don't think it matters 
because it is not related to my video problem.

Do you have any idea?

Thank you.
Best regards.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]